BETA

13th November 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [13/11/17 01:04 AM] with 'Major Outage'

Issue has been resolved at [13/11/17 01:13 AM]