BETA

12th November 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [12/11/17 04:09 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [12/11/17 04:19 PM]