BETA

22nd June 2026

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/06/26 01:37 PM] with 'Partial Outage'

Issue has been resolved at [22/06/26 01:40 PM]