BETA

22nd March 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/03/19 10:11 AM] with 'Partial Outage'

Issue has been resolved at [22/03/19 10:12 AM]