BETA

22nd March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [22/03/19 09:55 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [22/03/19 10:02 AM]