BETA

12th November 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [12/11/17 02:00 PM] with 'Major Outage'

Issue has been resolved at [12/11/17 02:01 PM]