BETA

22nd March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [22/03/19 09:33 AM] with 'Partial Outage'

Issue has been resolved at [22/03/19 09:35 AM]