BETA

12th November 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [12/11/17 09:03 AM] with 'Major Outage'

Issue has been resolved at [12/11/17 09:08 AM]