BETA

12th November 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [12/11/17 02:21 AM] with 'Partial Outage'

Issue has been resolved at [12/11/17 02:22 AM]