BETA

22nd March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [22/03/19 09:24 AM] with 'Partial Outage'

Issue has been resolved at [22/03/19 09:25 AM]