BETA

22nd March 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/03/19 09:15 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [22/03/19 09:23 AM]