BETA

24th September 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [24/09/16 04:49 AM] with 'Partial Outage'

Issue has been resolved at [24/09/16 04:54 AM]