BETA

10th November 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [10/11/17 01:56 PM] with 'Partial Outage'

Issue has been resolved at [10/11/17 01:57 PM]