BETA

10th November 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [10/11/17 11:22 AM] with 'Major Outage'

Issue has been resolved at [10/11/17 11:27 AM]