BETA

9th November 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [09/11/17 02:46 PM] with 'Partial Outage'

Issue has been resolved at [09/11/17 02:47 PM]