BETA

8th November 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [08/11/17 07:03 AM] with 'Partial Outage'

Issue has been resolved at [08/11/17 07:04 AM]