BETA

7th November 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [07/11/17 01:44 PM] with 'Partial Outage'

Issue has been resolved at [07/11/17 01:54 PM]