BETA

22nd March 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/03/19 05:36 AM] with 'Partial Outage'

Issue has been resolved at [22/03/19 05:37 AM]