BETA

6th November 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [06/11/17 01:02 PM] with 'Partial Outage'

Issue has been resolved at [06/11/17 01:03 PM]