BETA

6th November 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [06/11/17 10:54 AM] with 'Partial Outage'

Issue has been resolved at [06/11/17 11:06 AM]