BETA

15th January 2026

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [15/01/26 12:20 PM] with 'Major Outage'

Issue has been resolved at [15/01/26 12:35 PM]