BETA

5th November 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [05/11/17 07:38 PM] with 'Partial Outage'

Issue has been resolved at [05/11/17 07:39 PM]