BETA

21st September 2016

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [21/09/16 01:14 AM] with 'Partial Outage'

Issue has been resolved at [21/09/16 02:35 AM]