BETA

2nd November 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [02/11/17 11:46 AM] with 'Major Outage'

Issue has been resolved at [02/11/17 11:47 AM]