BETA

2nd November 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [02/11/17 11:46 AM] with 'Partial Outage'

Issue has been resolved at [02/11/17 11:47 AM]