BETA

21st March 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [21/03/19 07:09 PM] with 'Partial Outage'

Issue has been resolved at [21/03/19 07:11 PM]