BETA

2nd November 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [02/11/17 11:40 AM] with 'Major Outage'

Issue has been resolved at [02/11/17 11:41 AM]