BETA

2nd November 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [02/11/17 11:40 AM] with 'Partial Outage'

Issue has been resolved at [02/11/17 11:54 AM]