BETA

21st March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [21/03/19 06:15 PM] with 'Major Outage'

Issue has been resolved at [21/03/19 06:17 PM]