BETA

2nd November 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [02/11/17 11:23 AM] with 'Major Outage'

Issue has been resolved at [02/11/17 11:24 AM]