BETA

19th September 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [19/09/16 10:35 AM] with 'Partial Outage'

Issue has been resolved at [19/09/16 10:40 AM]