BETA

21st March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [21/03/19 05:59 PM] with 'Partial Outage'

Issue has been resolved at [21/03/19 06:05 PM]