BETA

21st March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [21/03/19 04:05 PM] with 'Partial Outage'

Issue has been resolved at [21/03/19 04:06 PM]