BETA

21st March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [21/03/19 03:55 PM] with 'Partial Outage'

Issue has been resolved at [21/03/19 03:56 PM]