BETA

28th October 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [28/10/17 10:50 AM] with 'Major Outage'

Issue has been resolved at [28/10/17 10:51 AM]