BETA

27th October 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [27/10/17 03:00 PM] with 'Partial Outage'

Issue has been resolved at [27/10/17 03:05 PM]