BETA

24th October 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [24/10/17 04:13 PM] with 'Partial Outage'

Issue has been resolved at [24/10/17 04:15 PM]