BETA

17th September 2016

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [17/09/16 03:26 AM] with 'Partial Outage'

Issue has been resolved at [17/09/16 04:04 AM]