BETA

18th October 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [18/10/17 12:00 AM] with 'Major Outage'

Issue has been resolved at [18/10/17 12:01 AM]