BETA

17th October 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [17/10/17 11:48 PM] with 'Major Outage'

Issue has been resolved at [17/10/17 11:49 PM]