BETA

17th October 2017

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [17/10/17 10:16 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [18/10/17 01:01 AM]