BETA

15th September 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [15/09/16 01:29 AM] with 'Partial Outage'

Issue has been resolved at [15/09/16 01:33 AM]