BETA

17th October 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [17/10/17 07:47 PM] with 'Partial Outage'

Issue has been resolved at [17/10/17 07:49 PM]