BETA

13th September 2016

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [13/09/16 11:44 PM] with 'Major Outage'

Issue has been resolved at [13/09/16 11:48 PM]