BETA

17th October 2017

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [17/10/17 06:48 PM] with 'Partial Outage'

Issue has been resolved at [17/10/17 06:49 PM]