BETA

15th October 2017

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [15/10/17 01:36 PM] with 'Partial Outage'

Issue has been resolved at [15/10/17 02:09 PM]