BETA

15th October 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [15/10/17 12:49 PM] with 'Partial Outage'

Issue has been resolved at [15/10/17 12:50 PM]