BETA

14th October 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [14/10/17 01:48 PM] with 'Partial Outage'

Issue has been resolved at [14/10/17 01:50 PM]