BETA

14th October 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/10/17 01:14 PM] with 'Major Outage'

Issue has been resolved at [14/10/17 01:15 PM]