BETA

10th September 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [10/09/16 12:57 AM] with 'Partial Outage'

Issue has been resolved at [10/09/16 01:06 AM]